IDE NetBeans Framework

Prérequis et téléchargement de l’IDE NetBeans

NetBeans est un IDE open source. En plus de Java, NetBeans supporte également différents autres langages, comme C, C++, JavaScript, XML PHP, HTML  de façon native ainsi que bien d’autres (comme Python ou Ruby) par l’ajout de greffons

Prérequis

Le Java SE Development Kit (JDK) 7 Mise à jour 10 (ou version ultérieure) ou JDK 8 est requis pour installer l’EDI NetBeans. Vous pouvez télécharger la dernière mise à jour du JDK 7 et du JDK 8 à cette Adresse

Seuls PHP et C/C++ nécessitent que Java Runtime Environment (JRE) 7 ou 8 soit  installé et exécuté.  JavaFX 2.2 est livré avec la dernière JDK 7 pour Windows, Mac et Linux.

JDK 8 est nécessaire pour utiliser les fonctions JavaFX 8 dans l’IDE NetBeans 8.0.2.

JavaFX 8 est livré avec le JDK 8 pour Windows, Mac et Linux.

Contrairement aux versions précédentes de l’IDE NetBeans, NetBeans 8.0.2 ne nécessite pas que vous configurez une plate-forme Java “FX-activé” afin d’utiliser le support JavaFX.

Pour utiliser les fonctionnalités de JavaFX dans NetBeans IDE, nous vous recommandons fortement de mettre à jour votre version de JDK 7 Mise à jour 10 (ou plus récent) ou utilisez JDK 8 avant de passer au téléchargement.

Téléchargement

Sur page de téléchargement de  l’IDE NetBeans, vous pouvez en obtenir un de plusieurs installeurs, dont chacun contient l’IDE et des outils supplémentaires de base.

Les options d’installation suivantes sont disponibles:

  • Java SE.Prend en charge tout le développement Java SE, fonctionnalités standard ainsi que le support  au développement sous  la plate-forme NetBeans et JavaFX SDK 2.2 (ou plus récent) ou JavaFX SDK 8 EA.
  • Java EE.Fournit des outils pour développer des applications Java SE et Java EE ainsi que le support  pour le développement sous plate-forme NetBeans et JavaFX SDK 2.2 (ou plus récent) ou JavaFX SDK 8 EA. Cette option de téléchargement comprend également le  serveur GlassFish édition Open Source 4.1 et le logiciel Apache Tomcat 8.0.15.
  • C / C ++.Prend en charge le développement dans les langages  C, C ++, Qt, Fortran.
  • Fournit des outils pour le développement de PHP 5.x, Zend Framework, Symfony Framework.
  • C’est  est une option de téléchargement complet, qui contient tous les runtimes et technologies disponibles pour l’EDI NetBeans.
  • Aller à http://netbeans.org/downloads/.
  • Dans la partie supérieure droite de la page, sélectionnez la langue et la plate-forme à partir de la liste déroulante. Vous pouvez également choisir de télécharger et d’utiliser le fichier zip indépendant de la plateforme.
  • Cliquez sur le bouton Télécharger pour l’option de téléchargement que vous voulez installer.
  • Enregistrez le fichier d’installation sur votre système.
0 Commentaires

Laisser une réponse

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

*

©2017 Sitatech Group Ltd. All rights reserved - société au capital de 50.000,00 euros

Vous connecter avec vos identifiants

ou    

Vous avez oublié vos informations ?

Create Account